Platform Accessibility Limited
Incident Report for Funraise
Resolved
Funraise Platform is back in action and lightning fast. If you experience any further issues today, let us know!
Posted over 1 year ago. Oct 21, 2016 - 14:30 PDT
Monitoring
A DDoS attack affecting a huge section of the internet has affected the accessibility of the Funraise Platform in some instances. We are monitoring the issue and will let you know when we are back to normal. This DDoS attack today affected the big dogs like Twitter and Spotify, read more here: https://techcrunch.com/2016/10/21/many-sites-including-twitter-and-spotify-suffering-outage/
Posted over 1 year ago. Oct 21, 2016 - 09:00 PDT